Help for nms compatibility or fix for 1.8

Discussion in 'Plugins' started by kbabe, Apr 10, 2017.

Thread Status:
Not open for further replies.
  1. kbabe

    kbabe kbabe#9563 Premium

    Minecraft Accounts: Embalming
    Messages:
    85
    Reactions:
    +33
    I have a fully completed practice plugin, but it's made with nms(world loading). it uses a maps folder to use region data and locations to determine spawns and has separate void worlds to reduce lag for players.
    We have a custom spigot which is made with a base of 1.8 that supports 1.7.10, but 1.8 spigot builds cant use nms(or so I think they cant) and need to be able to convert it to 1.7.10.
     
  2. Scarger

    Scarger Member

    Minecraft Accounts: scarger17
    Messages:
    71
    Reactions:
    +19
    NMS is incorporated in all versions of spigot, it's just that class names change frequently which causes it to be hard to make things cross-version compatible.
     
    • Agree Agree x 1
Thread Status:
Not open for further replies.